Buscar

Truco de Excel: ¿Cómo hacer un cuadro de busqueda para tus datos?


 
 Old 12 oct 2005, 07:42   #1 (permalink)  
Nuevo miembro
 
Avatar de maxert
 
Registrado: septiembre 2005
Mensajes: 27

Idea Truco de Excel: ¿Cómo hacer un cuadro de busqueda para tus datos?

Esta funcion es muy util sobre todo si quieres que con solo meter un texto o un codigo ya sea numérico o alfanumérico te devuelva la informacion solicitada, sobre todo es muy util en empresas para hacer pedidos, facturas hacer un catalogo de productos o una base de datos de tus contactos o libros

Primero ordenen sus datos alfabeticamente.

http://img376.imageshack.us/img376/8107/exel31bd.jpg

Armen la tabla con todas su entradas como ven a continuación

http://img365.imageshack.us/img365/2420/excel2xo.jpg

luego seleccionan la celda donde quieren que aparesca el dato que quieren y en el menu Insertar seleccionen funcion y en funciones de busqueda y referencia busquen BUSCARV o si pueden lo hacen manualmente en la misma celda esta función:

=BUSCARV(valor_buscado;matriz_buscar_en;indicador_ columnas;ordenado)

http://img152.imageshack.us/img152/1171/excel459py.png

El valor buscado va a ser la celda en la cual van a poner el texto para que la formula les de vuelva los dato que ustedes quieren. En mi caso es C3

la matriz_buscar_en son los datos que quieres que aparesca, claro sin los encabezados debes seleccionar toda la tabla. En este caso es A2:F27, algo importante: es mejor bloquear los rangos de las tablas con referencias absolutas para asi serciorarse que todas las entradas tengan el mismo rango de celdas. para eso cuando seleccionen las celdas coloquen el cursor en el rango de celdas y presionen la tecla F4 veran que la celda se le agragaron unos simbolos como el que aparece en el ejemplo

el indicador de columnas es el numero de la columna que corresponde a la entrada, en este caso la entrada titulo es la segunda columna por lo cual se coloca 2

ordenado es como quieres te busque, si pones VERDADERO te buscara la coincidencia por orden alfabetico, si no tienen la tabla en orden alfabetico puede que les de un dato inexacto, mientras que si ponen FALSO se busca la coincidencia mas exacta aunque no este en orden alfabetico.

Luego le dan a enter o aceptar y listo!, y continuan con las demas entradas es lo mismo solo cambia el indicador de columnas.


Espero que les sea de utilidad, cualquier duda avisenme ok.

Salu2

Maxert
maxert is offline   Citar y responder
 
 Old 13 oct 2005, 13:43   #2 (permalink)  
Miembro
 
Avatar de Carok
 
Registrado: julio 2004
Ubicación: Santiago de Compostela (Galicia)
Mensajes: 76

Predeterminado Re: Truco de Excel: ¿Cómo hacer un cuadro de busqueda para tus datos?

Muy bien currao, para sólo ser una opción del programa

Carok is offline   Citar y responder

« curiosidad en word | Acelerar la navegacion de firefox »

Herramientas
Estilo


 

Tema Iniciado por Foro Respuestas Último mensaje
busco programa para hacer "musica" pendejoo Sonido 16 07 feb 2007 20:26
posicionamiento en Google herlanz Internet 23 20 mar 2006 19:40
Programa para hacer radio rogeryerro Software 2 29 mar 2005 01:44



Buscar